
Microsoft Excel 2003: Part IV 
Custom Tools for Worksheets 

Windows XP 
 

 
 

Microsoft Excel 2003  
 

Microsoft Excel is an electronic spreadsheet program.  Electronic spreadsheet 

applications allow you to type, edit, and print spreadsheets.  Excel can be used for 

financial, statistical, or list information.   

 

Customizing 

 

Name Box 

The name box displays the cell address of the active cell in the worksheet (the 

cell that has the black outline which surrounds the cell that you can move using 

the mouse or keyboard).  You can also use the name box to name a cell or range of 

cells so that you can quickly go to them or refer to them in a formula.  

 

To Create a Name 

• Select the cell or range of cells to be named. 

• Click within the Name Box to the left of the Formula Bar. 

• Type a name and press Enter.  The name cannot have any spaces, 

however you may use the Underscore key (Shift + hyphen).  For 

Example:  electronic_services 

OR 

• Open the Insert menu and from the Name submenu select Define… 

Copyright © 2005 ASCPL All Rights Reserved                 MS Excel 4 10/24/2005 12:28:29 PM/JS 
1 



• In the Names in Workbook text box type the name that you want for the 

cell or range of cells. 

• Press Enter or click OK. 

Using Names 

Later, when you are in another area of the workbook you can click the down arrow 

next to the Name Box and click on a name to select it.  Excel will then take you to 

that area of the worksheet.  Using the Go To option (Edit-Go To) you can select a 

named area.  Also when you are using formulas you can type the name you created 

in the Name Box to refer to the cell or range of cells. 

 
To Erase a Name 

 
• Open the Insert menu and from the Name submenu select Define… 

• Select the Name that you want to delete and click the Delete button. 

• Press Enter or click OK. 
 

Lists 

If you are creating a list or a pattern of numbers, Excel can help you to quickly finish 

the list.  You need to type at least the first three items in the list, and then select 

them.  There is a little black box (fill handle) in the corner of the outline of the 

selected area.  Click, hold, & drag this box.  Continue dragging 

until the list is complete (filled in). 

The Custom Lists are the days of the week and the months of the year.  If you would 

like to create additional custom lists: 

Fill 
Handle 

• Open the Tools menu 

• Select Options 

• Choose the Custom List tab.   

• Select New List, type the entries, and then click Add and OK.  Now you 

can use the Fill handle to quickly create your own lists.  
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Generate a List Automatically 
You can convert data into a list automatically.  Data must be arranged in columns 

with descriptive column headings for this method to work. 

 

• Click and drag to select the worksheet data including the column 

headings. 

• Click Data on the menu bar. 

• Click List. 

• Click Create List and confirm that the cells listed match the cells in your 

worksheet. 

 
• Click checkbox to confirm that the list has headers.  

• Click OK. You may see a warning about query tables in the worksheet. 

Click Yes. 

• Each column head now has an arrow indicating a drop-down column filter. 

 
 

Enter List Data Using a Form 

• Type a column head name for the first column.  

• Repeat step 1 to the adjacent cells 

until you have entered desired 

number of column heads.  
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• Click the cell in which you want to begin entering data. (In this case A1) 

• Click Data. 

• Click Form.  A data form appears for you to enter your data. 

 
• Type requested data in the fields pressing Tab to move to the next field.  

• After completing the first set of fields, click New to enter data and start a 

new record.  The data fills the worksheet, and the form clears for the new 

record. 

• Repeat steps 6 – 8 to enter each new record. 

• Click Close when you are done entering data. 
 

Import a Microsoft Word List 

• In a Word table, click and drag to select the cells you want to copy. 

• Click the Copy button. 

• In Excel, click a cell in the upper-left of the worksheet, making sure there 

are enough cells below to the right to accommodate the Word table. 

• Click the Paste button to insert the Word table into Excel worksheet. 

• To add more records, click the first cell of a new row.  

• Click Data then Form.  

• In the form, click New to start a new record. 

Copyright © 2005 ASCPL All Rights Reserved                 MS Excel 4 10/24/2005 12:28:29 PM/JS 
4 



 

Tools to Facilitate Creating and Managing Data Lists 

 

AutoComplete 

When you type duplicate data in the same column, Excel will AutoComplete the 

information for you.  For instance if you are typing a list that repeats a person’s 

name, you will just have to type the first letter or letters of the name that 

distinguishes it from the other names and Excel will complete the rest for you.  You 

just need to press Enter for the data to be accepted.  If you do not want to accept 

what Excel has completed, then just continue typing or press the spacebar, 

whatever is appropriate.  AutoComplete only looks at the data organized in columns. 

To turn off this feature:  open the Tools menu, select Options, and choose the 

Edit tab.  Remove the check in the check box to the left of Enable AutoComplete 
for cell values. 

 

Sort 

Sorting organizes data in ascending or descending order alphabetically or 

numerically. 

 

To sort by one or more columns: 

• Click anywhere within the area you would like to sort. 

• Open the Data menu. 

• Select Sort… 

• Click the down arrow and select which column to Sort by. 

• Click the radio button (circle) to select Ascending or Descending. 
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Before: After:

• For multiple sorts, click the down arrow and select which column to sort 

second and third (Then by).  Also selecting Ascending or Descending. 

Multiple Sort Example:  

• In the My list has area 

of the dialog box, click 

the radio button to select 

if you have a Header 
row (labels at the top of the columns) or No header row.  (If the correct 

selection is not already marked.) 

• When finished click the OK button. 

Note:  If you are sorting rows, then click Options and change the Orientation to 

Sort left to right.  Just remember to change it back when you resume sorting 

columns. 

 

OR 
 
To sort by one column: 

• Click within the column. 

• Click one of the sort buttons on the Standard toolbar.  

• The list will be sorted or organized in either Ascending 

 or Descending  order depending on which button you selected. 

Note:  It is important to just click within the column that you want to sort by.  Do NOT 
select any of the worksheet or the information may get separated from the 

appropriate row. 
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AutoFilters 
If you have a lot of information you may want to filter out a smaller list to view or print 

for a particular purposes.  To do this you will use AutoFilter. 

 

To start AutoFilter: 

• Create a list and include labels (a header row). 

• Click anywhere within the list. 

• Open the Data menu. 

• Select Filter. 
In the Filter submenu, select AutoFilter. 
 

To use AutoFilter: 

• When AutoFilter is on, down arrows will appear next to each heading.  

Clicking the arrows will open a drop-down list.   

• Click on what you would like to filter out of the list.  This can be done for 

each heading.  Notice that the arrow changes color after you select a filter.  

This will help you identify which columns have been filtered. 

 

To unfilter the lists: 

• Click the down arrow and select (All).  This would need to be done for 

each heading that you filtered. 

OR 

• Open the Data menu and from the Filter submenu select Show All. 
 

To turn off AutoFilter: 

• Open the Data menu, select Filter, and click AutoFilter once again.  The 

check will be removed in the menu and so will the arrows next to the 

headings within the header row of the worksheet. 
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Note:  When inputting data into a worksheet, it is best to divide the information into 

the smallest parts.  For example instead of a column entitled Name, the data is 

broken down into Last Name and First name.  Also instead of a column labeled 

Address, the address is broken down into separate columns for Street Number, 

Street, City, State, and Zip.  This allows the worksheet to be easily filtered and 

sorted. 

 

Shortcut:  If you use AutoFilter often, then you may want to add the AutoFilter 

shortcut button to the Standard toolbar.   This can be done by clicking the Toolbar 

Options button at the end of the Standard toolbar and then selecting Add or Remove 

Buttons.  Then you would need to choose Standard and lastly the AutoFilter 

button. 

 

Viewing Different Parts of a Worksheet at the Same Time 

Split 

Split allows you to view different sections of a worksheet at the same time.  The 

different sections can be side by side allowing you to view needed areas and even 

paste data. 

 

To split the worksheet into multiple panes: 
Move the active cell or select the row or column that is below or to the right of the 

area that you want split. 

Open the Window menu and select Split. 
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To remove the split: 
Open the Window menu and select Remove Split. 

 
 

Freeze 

When freeze is selected, areas of the worksheet are frozen while the rest of the 

worksheet is able to be scrolled.  For instance if you have headings at the top of 

columns of data, the headings can be frozen and as you type data or scroll through 

the worksheet the headings will still be visible.  

 

To freeze the worksheet: 

Move the active cell or select the row or column that is below or to the right of the 

area that you want split. 

Open the Window menu and select Freeze Panes. 

 

To remove the freeze: 

Open the Window menu and select Unfreeze Panes. 
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Charts 
 

Creating Charts 

•  Click and select the worksheet data you 

want to chart. 

• Click the Chart Wizard button.    

• In the Chart Wizard Dialog Box:  

• Click a chart type. 

• Click a chart sub-type. 

• Click Next. 
 

 

• The Chart Wizard Step 2 
Screen Appears:  

• Confirm the selected data 

range of cells. 

• Click to arrange data in rows 

or columns. 

• Click Next. 
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• The Chart Wizard Step 3 Screen Appears: 
 

 
 

 

• Type a chart title. 

• Type a name for the x and y axes. 

• Click Next. 
 

• The Chart Wizard Step 4 Screen appears: 
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• Click to indicate whether to locate your chart on a separate sheet. 

• Click Finish. 

 

Modifying Chart Details 

• Double-clicking on any of the chart components will bring up a formatting 

dialog box. You may make your changes here and click OK. 

• Here is an example of the formatting dialog box for the chart title: 

 
Change Size of Charts 

• Click on blank portion of chart. You should see black tabs appear on 

border of chart. 

• Click and drag black tabs in order to resize chart. 

 
Change Type of Chart 

• Right click on blank portion of chart. A menu will appear. 

• Select Chart Type from the menu. 

• Choose your new chart type. Press OK. 
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Exercises 

 

 

Exercise 1 
Creating a Name:  Page 2 

1. Using the travel expense log file, highlight the row for John 

Watkins and assign the name Watkins to those cells. Scroll down 

to the bottom of the worksheet and then use the name box to 

relocate to the Watkins cells. 

 

Exercise 2 
Making a List Page 2 - 4 

1. Create a new file (workbook) and type in the following column 

heads: 

• First Name 

• Last Name 

• City  

• State  

 

2. Enter data into the form for yourself and 4 other people you know. 

 

Exercise 3 
AutoComplete, Sort, AutoFilters Page 4 & 5 
 

1. Using the file you just created, sort your records in descending 

alphabetical order by the last name. 

2. Below your data select an empty cell and type “January”.  Use 

AutoComplete to create a row with all 12 months.  Enter yourself 

and your friends’ names next to their month of birth. 
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3. Using the travel expense log file, select the AutoFilter option and 

filter out the salespeople who’s Registration equals $500. 

 

Exercise 4 
Split & Freeze   Page 6 & 7 

1. Using the travel expense log file, split the data at the 25th 

salesperson. Close the file when you are done. 

2. Reopen the travel expense log file and freeze the name column of 

the worksheet. 

Exercise 5 
Creating a Chart Page 7 

1. Using the travel expense log file, filter the Total column into Top 
10 items. Create a chart based on the Top 10 results.  

2. Name the chart “Top 10 Salespeople”.  

3. Place the chart at the bottom of the worksheet data. 

 
Exercise 6 

Modifying a Chart Page 9 
1. Change the color of the chart to RED. 

2. Expand the size of the chart so that all column headings and 

salespeople 

are shown. 

3.   Change the type of chart. 
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